synopsys arc architecture · Supported
Maintainers
- M Vineet Gupta <vgupta@kernel.org>
Paths
- F
Documentation/arch/arc - F
Documentation/devicetree/bindings/arc/* - F
Documentation/devicetree/bindings/interrupt-controller/snps,arc* - F
arch/arc/ - F
drivers/clocksource/arc_timer.c - F
drivers/tty/serial/arc_uart.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-arch (capped at 30), ordered by date desc.
-
DORMANTno replies
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
2026-05-19 · Ethan Nelson-Moore <hidden> -
STALE87d
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE87d
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE164d
[GIT PULL] asm-generic header updates for 7.0
2026-02-10 · "Arnd Bergmann" <arnd@arndb.de> -
STALE188d
[PATCH] mm/pgtable: convert pgtable_t to ptdesc pointer
2026-01-07 · alexs@kernel.org -
STALE248d
[PATCH 2/7] arc: mm: enable MMU_GATHER_RCU_TABLE_FREE
2025-11-14 · Qi Zheng <qi.zheng@linux.dev> -
STALE288d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE288d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE288d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE288d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE288d
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
2025-09-13 · Askar Safin <hidden> -
STALE373d
[PATCH 1/1] uapi/termios: remove struct ktermios from uapi headers
2025-07-16 · "H. Peter Anvin" <hpa@zytor.com> -
STALE456d
Re: [PATCH v12 06/28] riscv/mm : ensure PROT_WRITE leads to VM_READ | VM_WRITE
2025-04-24 · "Arnd Bergmann" <arnd@arndb.de> -
STALE476d
[PATCH v2 11/11] arch: Remove mk_pmd()
2025-04-02 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE476d
REVIEWED: 1 (0M) [PATCH v2 02/11] mm: Introduce a common definition of mk_pte()
2025-04-02 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE288d
[PATCH 05/41] arc: Replace __ASSEMBLY__ with __ASSEMBLER__ in the non-uapi headers
2025-03-14 · Thomas Huth <hidden> -
STALE288d
[PATCH 04/41] arc: Replace __ASSEMBLY__ with __ASSEMBLER__ in uapi headers
2025-03-14 · Thomas Huth <hidden> -
STALE432d
[PATCH v2 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE432d
[PATCH v2 12/13] arch, mm: introduce arch_mm_preinit
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE432d
[PATCH v2 11/13] arch, mm: streamline HIGHMEM freeing
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE432d
[PATCH v2 10/13] arch, mm: set high_memory in free_area_init()
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE432d
[PATCH v2 09/13] arch, mm: set max_mapnr when allocating memory map for FLATMEM
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE497d
[PATCH 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE497d
[PATCH 12/13] arch, mm: introduce arch_mm_preinit
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE497d
[PATCH 11/13] arch, mm: streamline HIGHMEM freeing
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE497d
[PATCH 10/13] arch, mm: set high_memory in free_area_init()
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE497d
[PATCH 09/13] arch, mm: set max_mapnr when allocating memory map for FLATMEM
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE471d
REVIEWED: 2 (0M) [PATCH v7 3/6] syscall.h: introduce syscall_set_nr()
2025-03-03 · Dmitry V. Levin <hidden> -
STALE471d
REVIEWED: 2 (0M) [PATCH v7 2/6] syscall.h: add syscall_set_arguments()
2025-03-03 · Dmitry V. Levin <hidden> -
STALE519d
[PATCH 4/4] arch: Remove mk_pmd()
2025-02-21 · "Matthew Wilcox (Oracle)" <willy@infradead.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
DORMANTno replies
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
2026-05-19 · Ethan Nelson-Moore <hidden>